How do I make my character be inside the collision capsule


when I press play, my character sinks immediately to the ground. How do I make my character not sink? How do I make my character be inside the collision capsule? Is that something I have to fix in blender?

This could be caused by two things off the top of my head.

  1. Is the object origin where you want it to be in Blender?
  2. Looking at the collider capsule settings, it doesn’t seem to be centered. On the right side of the screen you see the Capsule Center transform vector. Looks like there are non-zero numbers in the X and Z values, this will move the center of that collision capsule away from the center while the Y influences the vertical position. You might want to check how it behaves with 0 on X and Z.

If that doesn’t work, it might be the first issue with the non-centered object origin in Blender.